Thursday, July 27, 2006

Flipper Condo in Trouble at Metrome #608

Based on the pictures and the late 2005 closing date this condo has never been lived in. This is also interesting as most of examples of price decline are units purchased from flippers who bought from the developers. This unit was only changed hands once.

The loss figure below does not include negative cash flow, cost of staging and also assumes an unlikely full price offer.

Resale Price: $385,000
Cost: $381,200

Loss@6% Sales Expenses: $19,300

Bedrooms: 1
Bathrooms: 1
Square Feet: 716

Purchase Date: 10/25/2005
Holding Period: 9 months and counting...

Purchase Details: view

8 comments:

Anonymous said...

I'm not a great math guy, but it might be more effective to also include the % loss on each transaction, as well as an annualized % loss. If a guy lost 10% in 6 months, it's more dramatic saying he lost 20% on an annualized rate... just a thought.

Mr. Brightside said...

I will seriously consider adding some more details to the listings.

I'm curious, do you ever see property selling below cost when you're doing your own research or is this your main source for seeing specific examples of the market decline?

I find that the aggregate numbers that come out periodically aren't very useful, even a standard comp analysis isn't that good since appraisals are qualitative and while better than aggregate numbers not as good as the actual property selling at a loss.

Thanks for dropping by

MrManFitz said...

Your "Purchase Details" links never work for me. What's the deal?

Mr. Brightside said...

I've seen the links break because the County's server is down. I've also made code mistakes before but have fixed them when they come up.

Did the Metrome link not work for you? It works for me in both Firefox and Internet Explorer.

Finally what happens when you click the link? Error message or nothing? You might also try a right click and "open in new window".

MrManFitz said...

It doesn't work in IE or Firefox. The error is this:

"Firefox can't find the server at www2.sdcounty.ca.gov"

Mr. Brightside said...

I can say that I'm truly stumped on this one, it works for me on three computers using each browser.

Does every link fail you or just this one for the Metrome loss?

MrManFitz said...

None of the links have ever worked. Am I the only one? I even tried using the parcel parameters from one of your links at the sdarcc.com search page and that page doesn't work either:

http://www.sdarcc.com/arcc/services/propsales_search.aspx

Very weird.

Mr. Brightside said...

MrManFritz,

Nobody else has complained and I do have access to several computers and it works on all of them. Very strange!

Do you work for the county of otherwise have any non-standard networking taking place? It's possible it's a DNS or if you're internal on a Microsoft network an Active Directory issue.

If you're at a friends house or internet cafe try it from a computer that's totally unrelated and see how it works.

Also note that I've started putting about everything in the posts anyway so that county site isn't as important as it used to be.

Thanks again for stopping by!